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Configuring SNMP traps

This article describes how to manage alert settings, SNMP trap notification, and SNMP request authentication, and to test SNMP trap reports for VSP G350, VSP G370, VSP G700, VSP G900, VSP F350, VSP F370, VSP F700, and VSP F900.

For more details on the SNMP implementation details, see SNMP overview. The following reference information is also available:

Accessing the Alert Notifications window

You can configure SNMP traps using the Alert Notifications window in the maintenance utility.

Before you begin

You must have the Storage Administrator (Initial Configuration) role to perform this task.

Procedure

  1. Display the Device Manager - Storage Navigator main window.

  2. From the Maintenance Utility menu, select Alert Notifications.

  3. In the Alert Notifications window, click Set Up.

  4. In the Set Up Alert Notifications window, select the SNMP tab.

    GUID-8A795082-9989-49F0-9F30-239A2E2089C1-low.png
  5. For Notification Alert, select one of the following:

    • All (Sends alerts of all SIMs.)
    • Host Report (Sends alerts only of SIMs that report to hosts. Alert destinations are common to Syslog, SNMP, and Email.)
  6. Confirm the settings, and then click Apply.

Managing SNMP trap notification

Use the procedure for the SNMP version you use to set SNMP trap notification. The items to specify are different depending on the SNMP version.

Adding trap notification for SNMP v1 and v2c

Follow this procedure to add IP addresses and communities to trap notification for SNMP versions v1 and v2c.

  1. Display the Device Manager - Storage Navigator main window.

  2. From the Maintenance Utility menu, select Alert Notifications.

  3. In the Alert Notifications window, click Set Up.

  4. In the Set Up Alert Notifications window, select the SNMP tab.

  5. Under SNMP Agent, click Enable.

  6. Under SNMP Version, select v1 or v2c.

  7. Under Registered Sending Trap Settings, click Add.

  8. In the Add Sending Trap Setting window, under Community, complete one of the following:

    • If you select an existing community, uncheck the New checkbox, and then select from the list of existing community names.
    • If you add a new community, check the New check box, and then enter a community name.

    You can enter up to 180 letters, numbers, and symbols, except the following:

    " \ ; : , * ? < > | / ^ & % '

    Do not use a space at the beginning or end of the name.

  9. Under Send Trap To, complete the following:

    • To enter a new IP address, check the New check box. Select IPv4 or IPv6 for the version of the IP address, and then enter an IP address.
    • To use an existing IP address, uncheck the New check box. Select an existing IP address from the pull-down menu.

    • To add more IP addresses, click Add IP Address to add input fields.
    • To delete an IP address from Send Trap to, click the - button to delete the IP address.
    NoteAny IP address that has all values set to zero (0) cannot be specified for IPv4 and IPv6. The IPv6 address is specified by entering eight hexadecimal numbers that are separated by colons (:) using a maximum of 4 digits from zero (0) to FFFF, inclusive. The default form of the IPv6 address can be specified.
  10. Click OK.

    The IP address and community you entered are added to the Registered Sending Trap Settings table.
  11. Confirm the settings, and then click Apply.

Adding trap notification for SNMP v3

Follow this procedure to add IP addresses and users to trap notification for SNMP v3.

  1. Display the Device Manager - Storage Navigator main window.

  2. From the Maintenance Utility menu, select Alert Notifications.

  3. In the Alert Notifications window, click Set Up.

  4. In the Set Up Alert Notifications window, select the SNMP tab.

  5. Under SNMP Agent, click Enable.

  6. Under SNMP Version, select v3.

  7. Under Registered Sending Trap Settings, click Add.

  8. In the Add Sending Trap Setting window, under Send Trap To, select IPv4 or IPv6 and enter an IP address.

    NoteAny IP address that has all values set to zero (0) cannot be specified for IPv4 and IPv6. The IPv6 address is specified by entering eight hexadecimal numbers that are separated by colons (:) using a maximum of 4 digits from zero (0) to FFFF, inclusive. The default form of the IPv6 address can be specified.
  9. Under User Name, enter a user name.

    Note

    If you use a user name that has already been specified for Sending Trap Setting or Request Authentication Setting, specify the same settings for the following options that were specified for that name. Otherwise, SNMP traps might not be sent correctly.

    • Authentication
    • Authentication - Protocol
    • Authentication - Password
    • Encryption
    • Encryption - Protocol
    • Encryption - Key

    You can enter up to 32 letters, numbers, and symbols, except the following:

    " \ ; : , * ? < > | / ^ & %

    Do not use a space at the beginning or end of the name.

  10. Under Authentication, select whether to Enable or Disable authentication.

    If you select Enable, complete the following steps:
    1. For Protocol, select an authentication type.

    2. For Password, enter a password.

  11. Under Encryption, select whether to Enable or Disable encryption.

    If you select Enable, complete the following steps:
    1. For Protocol, select an encryption type.

    2. For Key, enter a key.

    3. For Re-enter Key, enter the same key for confirmation.

  12. Click OK.

    The IP address and user you entered are added to the Registered Sending Trap Settings table.
  13. Confirm the settings, and then click Apply.

Deleting SNMP trap notification

Follow this procedure to delete IP addresses and communities or users from SNMP trap notification.

Before you begin

You must have the Storage Administrator (Initial Configuration) role to perform this task.

Procedure

  1. Display the Device Manager - Storage Navigator main window.

  2. From the Maintenance Utility menu, select Alert Notifications.

  3. In the Alert Notifications window, click Set Up.

  4. In the Set Up Alert Notifications window, select the SNMP tab.

  5. Under SNMP Agent, click Enable.

  6. Under SNMP Version, select your SNMP version.

  7. Under Registered Sending Trap Settings, select one or more specific combinations of IP address and community or user, and then click Delete.

  8. Confirm the settings, and then click Apply.

Testing SNMP trap reports

Follow this procedure to test SNMP trap reporting by sending a test trap.

Before you begin

An IP address and community have been added in the Set Up Alert Notifications window.

You must have the Storage Administrator (Initial Configuration) role to perform this task.

Procedure

  1. Display the Device Manager - Storage Navigator main window.

  2. From the Maintenance Utility menu, select Alert Notifications.

  3. Select the SNMP tab.

  4. Click Send Test SNMP Trap.

    Reports the test SNMP trap to the community or user registered in the storage system. Reports the events registered in the storage system instead of the events that are set on the SNMP tab. If you want to test the events set on the SNMP tab, click Finish and apply to the storage system, and then report the test SNMP trap.
  5. Verify whether the SNMP trap report (reference code 7fffff) is received by the SNMP manager that has the IP address specified for Sending Trap Setting in the Alert Notifications window.

Troubleshooting

This chapter provides troubleshooting information for the Hitachi SNMP Agent.

Solving SNMP problems

This topic describes some problems that can occur with SNMP.

Problem

Causes and solutions

Information cannot be received by GET REQUEST, GETNEXT REQUEST, and GETBULK REQUEST operations.

Causes:

  • An SNMP Manager IP address and community or user have not been added.
  • GUM failure occurred.
  • A network environment error occurred.

Solutions:

Trap cannot be received.

Causes:

  • An SNMP Manager IP address and community or user have not been added.
  • GUM failure occurred.
  • A network environment error occurred.

Solutions: