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Configuring SNMP traps

This article describes how to manage alert settings, SNMP trap notification, and SNMP request authentication, and to test SNMP trap reports for your storage system.

For details about the SNMP implementation details, see SNMP overview. The following reference information is also available:

Accessing the Alert Notifications window

You can configure SNMP traps using the Alert Notifications window in the maintenance utility.

Before you begin

You must have the Storage Administrator (Initial Configuration) role to perform this task.

Procedure

  1. In the maintenance utility, open the Alert Notifications window by one of the following ways:

    • When you use Device Manager - Storage Navigator, from the Maintenance Utility menu in the main window, select Alert Notifications.
    • When you use Hitachi Storage Advisor Embedded, in the navigation bar, click GUID-CA45C81B-3B34-4B7C-A7B1-B48BD0B277D5-low.png (Settings), and then select Alert Notifications.
    • When you directly logged in to the maintenance utility, click Administration > Alert Notifications.
  2. In the Alert Notifications window, click Set Up.

  3. In the Set Up Alert Notifications window, select the SNMP tab.

  4. For Notification Alert, select one of the following:

    • All (Sends alerts of all SIMs.)
    • Host Report (Sends alerts only of SIMs that report to hosts. Alert destinations are common to Syslog, SNMP, and Email.)
  5. Confirm the settings, and then click Apply.

Managing SNMP trap notification

Use the procedure for the SNMP version you use to set SNMP trap notification. The items to specify are different depending on the SNMP version.

Note

Required operations on the SNMP Manager after maintenance

If you are using SNMP v3, and authentication and encryption are enabled for traps, the following operations are required on the SNMP Manager after maintenance operations (including replacement of controller boards). If you are asked by maintenance personnel, perform the following operations.

To check whether the SNMP version is SNMP v3, in the maintenance utility, check the setting for SNMP version in the SNMP tab in the Alert Notifications window. To check whether authentication or encryption is enabled for traps, check the setting for Sending Trap Setting in the SNMP tab in the Set Up Alert Notifications window.

  • Restart the SNMP Manager, or reregister the storage systems to be monitored on the SNMP Manager.
  • Test trap reports. (See Testing SNMP trap reports.)
  • Obtain the trap history in MIB raidExMibTrapListTable from the SNMP Manager, and then perform proper storage management for traps that are not yet confirmed. For details about the format of the trap history, see raidExMibTrapListTable.

Adding trap notification for SNMP v1 and v2c

Follow this procedure to add IP addresses and communities to trap notification for SNMP versions v1 and v2c.

  1. In the maintenance utility, open the Alert Notifications window.

  2. In the Alert Notifications window, click Set Up.

  3. In the Set Up Alert Notifications window, select the SNMP tab.

  4. Under SNMP Agent, click Enable.

  5. Under SNMP Version, select v1 or v2c.

  6. Under Registered Sending Trap Settings, click Add.

  7. In the Add Sending Trap Setting window, under Community, complete one of the following:

    • If you select an existing community, uncheck the New checkbox, and then select from the list of existing community names.
    • If you add a new community, check the New check box, and then enter a community name.

    You can enter up to 180 letters, numbers, and symbols, except the following:

    " \ ; : , * ? < > | / ^ & % '

    Do not use a space at the beginning or end of the name.

  8. Under Send Trap To, complete the following:

    • To enter a new IP address, check the New check box. Select IPv4 or IPv6 for the version of the IP address, and then enter an IP address.
    • To use an existing IP address, uncheck the New check box. Select an existing IP address from the pull-down menu.

    • To add more IP addresses, click Add IP Address to add input fields.
    • To delete an IP address from Send Trap to, click the - button to delete the IP address.
    NoteAny IP address that has all values set to zero (0) cannot be specified for IPv4 and IPv6. The IPv6 address is specified by entering eight hexadecimal numbers that are separated by colons (:) using a maximum of 4 digits from zero (0) to FFFF, inclusive. The default form of the IPv6 address can be specified.
  9. Click OK.

    The IP address and community you entered are added to the Registered Sending Trap Settings table.
  10. Confirm the settings, and then click Apply.

Adding trap notification for SNMP v3

Follow this procedure to add IP addresses and users to trap notification for SNMP v3.

  1. In the maintenance utility, open the Alert Notifications window.

  2. In the Alert Notifications window, click Set Up.

  3. In the Set Up Alert Notifications window, select the SNMP tab.

  4. Under SNMP Agent, click Enable.

  5. Under SNMP Version, select v3.

  6. Under Registered Sending Trap Settings, click Add.

  7. In the Add Sending Trap Setting window, under Send Trap To, select IPv4 or IPv6 and enter an IP address.

    NoteAny IP address that has all values set to zero (0) cannot be specified for IPv4 and IPv6. The IPv6 address is specified by entering eight hexadecimal numbers that are separated by colons (:) using a maximum of 4 digits from zero (0) to FFFF, inclusive. The default form of the IPv6 address can be specified.
  8. Under User Name, enter a user name.

    Note

    If you use a user name that has already been specified for Sending Trap Setting or Request Authentication Setting, specify the same settings for the following options that were specified for that name. Otherwise, SNMP traps might not be sent correctly.

    • Authentication
    • Authentication - Protocol
    • Authentication - Password
    • Encryption
    • Encryption - Protocol
    • Encryption - Key

    You can enter up to 32 letters, numbers, and symbols, except the following:

    " \ ; : , * ? < > | / ^ & %

    Do not use a space at the beginning or end of the name.

  9. Under Authentication, select whether to Enable or Disable authentication.

    If you select Enable, complete the following steps:
    1. For Protocol, select an authentication type.

    2. For Password, enter a password.

  10. Under Encryption, select whether to Enable or Disable encryption.

    If you select Enable, complete the following steps:
    1. For Protocol, select an encryption type.

    2. For Key, enter a key.

    3. For Re-enter Key, enter the same key for confirmation.

  11. Click OK.

    The IP address and user you entered are added to the Registered Sending Trap Settings table.
  12. Confirm the settings, and then click Apply.

Deleting SNMP trap notification

Follow this procedure to delete IP addresses and communities or users from SNMP trap notification.

Before you begin

You must have the Storage Administrator (Initial Configuration) role to perform this task.

Procedure

  1. In the maintenance utility, open the Alert Notifications window.

  2. In the Alert Notifications window, click Set Up.

  3. In the Set Up Alert Notifications window, select the SNMP tab.

  4. Under SNMP Agent, click Enable.

  5. Under SNMP Version, select your SNMP version.

  6. Under Registered Sending Trap Settings, select one or more specific combinations of IP address and community or user, and then click Delete.

  7. Confirm the settings, and then click Apply.

Testing SNMP trap reports

Follow this procedure to test SNMP trap reporting by sending a test trap.

Before you begin

An IP address and community have been added in the Set Up Alert Notifications window.

You must have the Storage Administrator (Initial Configuration) role to perform this task.

Procedure

  1. In the maintenance utility, open the Alert Notifications window.

  2. Select the SNMP tab.

  3. Click Send Test SNMP Trap.

    Reports the test SNMP trap to the community or user registered in the storage system. Reports the events registered in the storage system instead of the events that are set on the SNMP tab. If you want to test the events set on the SNMP tab, click Finish and apply to the storage system, and then report the test SNMP trap.
  4. Verify whether the SNMP trap report (reference code 7fffff) is received by the SNMP manager that has the IP address specified for Sending Trap Setting in the Alert Notifications window.

    Note

    If the SNMP trap report cannot be received, check the following to solve the problem:

Checking SNMP Engine ID

Follow this procedure to check the SNMP Engine ID for each CTL.

  1. In the web browser, specify the IP address of a CTL to start the maintenance utility.

    http(s)://IP-address-of-the-CTL/MaintenanceUtility/
  2. In the Administration pane, select Alert Notifications. In the SNMP tab, check the value of the SNMP Engine ID.

  3. Return to step 1, and check the SNMP Engine ID for the other CTL.

Troubleshooting

This chapter provides troubleshooting information for the Hitachi SNMP Agent.

Solving SNMP problems

This topic describes some problems that can occur with SNMP.

Problem

Causes and solutions

Information cannot be received by GET REQUEST, GETNEXT REQUEST, and GETBULK REQUEST operations.

Causes:

  • An SNMP Manager IP address and community or user have not been added.
  • GUM failure occurred.
  • A network environment error occurred.

Solutions:

Trap cannot be received.

Causes:

  • A network environment error occurred.
  • An SNMP Manager IP address and community or user have not been added.
  • A license is invalid.
  • A GUM status error continues after a failure or maintenance operation.

Solutions:

  • Fix the network environment error.
  • Add an IP address and community or user. (See Adding trap notification for SNMP v1 and v2c or Adding trap notification for SNMP v3.)
  • Enable the license.
  • Reboot the GUM.
  • Perform the following operations:
    • Restart the SNMP Manager, or reregister the storage systems to be monitored on the SNMP Manager.
    • Confirm that traps can be reported. (See Testing SNMP trap reports.)
    • Obtain the trap history in MIB raidExMibTrapListTable from the SNMP Manager, and then perform proper storage management for traps that are not yet confirmed. For details about the format of the trap history, see raidExMibTrapListTable.

Adding request authentication for SNMP v1 and v2c

Follow this procedure to add IP addresses and communities for request authentication for SNMP versions v1 and v2c.

Before you begin

You must have the Storage Administrator (Initial Configuration) role to perform this task.

Procedure

  1. In the maintenance utility, open the Alert Notifications window.

  2. In the Alert Notifications window, click Set Up.

  3. In the Set Up Alert Notifications window, select the SNMP tab.

  4. Under SNMP Agent, click Enable.

  5. Under SNMP Version, select v1 or v2c.

  6. Under Registered Request Authentication Settings, click Add.

  7. In the Add Request Authentication Setting window, under Community, complete one of the following:

    • If you add a new community, check the New check box, and then enter a community name.
    • If you select an existing community, uncheck the New check box, and then select from the list of existing community names.

    You can enter up to 180 letters, numbers, and symbols, except the following:

    " \ ; : , * ? < > | / ^ & % '

    Do not use a space at the beginning or end of the name.

  8. Under Request Permitted, complete the following:

    • If you want to allow REQUEST operations from all managers, select the All check box.
    • If you want to allow REQUEST operations only from specified managers, select IPv4 or IPv6 and enter an IP address, or select from the list of existing IP addresses.
    • If you enter a new IP address, check the New check box. Select IPv4 or IPv6 for the version of the IP address, and then enter an IP address.
    • If you use an existing IP address, uncheck the New check box. Select an existing IP address from the pull-down menu.
    • If you add more IP addresses, click Add IP Address to add input fields.
    • If you delete an IP address from Request Permitted, click the - button to delete the IP address.
    NoteAny IP address that has all values set to zero (0) cannot be specified for IPv4 and IPv6. The IPv6 address is specified by entering eight hexadecimal numbers that are separated by colons (:) using a maximum of 4 digits from zero (0) to FFFF, inclusive. The default form of the IPv6 address can be specified.
  9. Click OK

    The community and IP address that you entered are added to the Registered Request Authentication Settings table.
  10. Confirm the settings, and then click Apply.

Adding request authentication for SNMP v3

Follow this procedure to add IP addresses and users for SNMP v3 request authentication.

Before you begin

You must have the Storage Administrator (Initial Configuration) role to perform this task.

Procedure

  1. In the maintenance utility, open the Alert Notifications window.

  2. In the Alert Notifications window, click Set Up.

  3. In the Set Up Alert Notifications window, select the SNMP tab.

  4. Under SNMP Agent, click Enable.

  5. Under SNMP Version, select v3.

  6. Under Registered Request Authentication Settings, click Add.

  7. In the Add Request Authentication Setting window, under User Name, enter the user name you registered in the SNMP Manager.

    Note

    If you use a user name that has already been specified for Sending Trap Setting or Request Authentication Setting, specify the same settings for the following options that were specified for that name. Otherwise, SNMP traps might not be sent correctly.

    • Authentication
    • Authentication - Protocol
    • Authentication - Password
    • Encryption
    • Encryption - Protocol
    • Encryption - Key

    You can enter up to 32 letters, numbers, and symbols, except the following:

    " \ ; : , * ? < > | / ^ & %

    Do not use a space at the beginning or end of the name.

  8. Under Authentication, select whether to Enable or Disable authentication.

    If you select Enable, complete the following steps:
    1. For Protocol, select an authentication type.

    2. For Password, enter a password.

  9. Under Encryption, select whether to Enable or Disable encryption.

    If you select Enable, complete the following steps:
    1. For Protocol, select an encryption type.

    2. For Key, enter a key. (Enter a character string for the key common to the SNMP Manager and the SNMP Agent because the public key method is not used.)

    3. For Re-enter Key, enter the same key for confirmation.

  10. Click OK.

    The user you entered is added to the Registered Request Authentication Settings table.
  11. Confirm the settings, and then click Apply.

Adding trap notification for SNMP v1 and v2c

Follow this procedure to add IP addresses and communities to trap notification for SNMP versions v1 and v2c.

  1. In the maintenance utility, open the Alert Notifications window.

  2. In the Alert Notifications window, click Set Up.

  3. In the Set Up Alert Notifications window, select the SNMP tab.

  4. Under SNMP Agent, click Enable.

  5. Under SNMP Version, select v1 or v2c.

  6. Under Registered Sending Trap Settings, click Add.

  7. In the Add Sending Trap Setting window, under Community, complete one of the following:

    • If you select an existing community, uncheck the New checkbox, and then select from the list of existing community names.
    • If you add a new community, check the New check box, and then enter a community name.

    You can enter up to 180 letters, numbers, and symbols, except the following:

    " \ ; : , * ? < > | / ^ & % '

    Do not use a space at the beginning or end of the name.

  8. Under Send Trap To, complete the following:

    • To enter a new IP address, check the New check box. Select IPv4 or IPv6 for the version of the IP address, and then enter an IP address.
    • To use an existing IP address, uncheck the New check box. Select an existing IP address from the pull-down menu.

    • To add more IP addresses, click Add IP Address to add input fields.
    • To delete an IP address from Send Trap to, click the - button to delete the IP address.
    NoteAny IP address that has all values set to zero (0) cannot be specified for IPv4 and IPv6. The IPv6 address is specified by entering eight hexadecimal numbers that are separated by colons (:) using a maximum of 4 digits from zero (0) to FFFF, inclusive. The default form of the IPv6 address can be specified.
  9. Click OK.

    The IP address and community you entered are added to the Registered Sending Trap Settings table.
  10. Confirm the settings, and then click Apply.

Adding trap notification for SNMP v3

Follow this procedure to add IP addresses and users to trap notification for SNMP v3.

  1. In the maintenance utility, open the Alert Notifications window.

  2. In the Alert Notifications window, click Set Up.

  3. In the Set Up Alert Notifications window, select the SNMP tab.

  4. Under SNMP Agent, click Enable.

  5. Under SNMP Version, select v3.

  6. Under Registered Sending Trap Settings, click Add.

  7. In the Add Sending Trap Setting window, under Send Trap To, select IPv4 or IPv6 and enter an IP address.

    NoteAny IP address that has all values set to zero (0) cannot be specified for IPv4 and IPv6. The IPv6 address is specified by entering eight hexadecimal numbers that are separated by colons (:) using a maximum of 4 digits from zero (0) to FFFF, inclusive. The default form of the IPv6 address can be specified.
  8. Under User Name, enter a user name.

    Note

    If you use a user name that has already been specified for Sending Trap Setting or Request Authentication Setting, specify the same settings for the following options that were specified for that name. Otherwise, SNMP traps might not be sent correctly.

    • Authentication
    • Authentication - Protocol
    • Authentication - Password
    • Encryption
    • Encryption - Protocol
    • Encryption - Key

    You can enter up to 32 letters, numbers, and symbols, except the following:

    " \ ; : , * ? < > | / ^ & %

    Do not use a space at the beginning or end of the name.

  9. Under Authentication, select whether to Enable or Disable authentication.

    If you select Enable, complete the following steps:
    1. For Protocol, select an authentication type.

    2. For Password, enter a password.

  10. Under Encryption, select whether to Enable or Disable encryption.

    If you select Enable, complete the following steps:
    1. For Protocol, select an encryption type.

    2. For Key, enter a key.

    3. For Re-enter Key, enter the same key for confirmation.

  11. Click OK.

    The IP address and user you entered are added to the Registered Sending Trap Settings table.
  12. Confirm the settings, and then click Apply.